不自重者,取辱。不自长者,取祸。不自满者,受益。不自足者,博闻。
【终极兼容】WeixinApi功能恢复 进入全屏
line

一、鸣谢在先

感谢热心网友 @马越 提供的方案!

二、大家如何升级

  • 删掉之前对Android和iOS的hook模式
    • 删掉wxjs文件的引用
    • 删掉Api.hook的所有调用
  • 下载最新的WeixinApi.js,目前版本4.0
  • 为了确保无缓存,可手动给WeixinApi.js的引用加上?v=4.0的版本戳
  • 部署代码,It works!

三、免责声明

使用过程中如果遇到问题,可以到github或者本站留言,我可以抽时间帮大家分析问题.
但是WeixinApi的使用权在各位,敢用就别怕出问题,出问题就要敢自己担责

四、建议在后

微信官方正在倒腾最新版的wxjs-sdk,出来以后,大家可以用新的、官方的!

趣店(原趣分期)技术学院
重点关注技术架构、服务化、优秀工具、自动化平台、开发全流程一体化解决方案、新人培养、工程师进阶之道等方面
这里环境优雅、氛围年轻、主要是福利还多,还等什么?我们敞开技术的大门,欢迎各种工程师加入!

评论区域

line
  • 时代人 2015-12-23 15:36:03 回复
    已经完全不能用了,点击发送给朋友及分享到朋友圈,都完全没有反应了。咱办了
  • androidwj 2015-03-06 17:21:55 回复
    已经完全不能用了,点击发送给朋友及分享到朋友圈,都完全没有反应了。bye。。。
  • 涛舅舅 2015-02-12 11:57:01 回复
    我写了一篇《JS-SDK分享接口的配置说明》,有困惑的朋友可以去我论坛上看~ 
    
    点我名字(上方蓝色字)
  • fox 2015-02-10 12:58:15 回复
    6.1.1 的回调失效了,点分享无法分享,如何解决啊,提供下思路也行。
  • fox 2015-02-09 21:56:41 回复
    微信6.0里分享取消后,还是执行分享成功的回调。有谁遇到过吗?
  • 涛舅舅 2015-02-06 22:06:34 回复
    老老实实整微信官方的js-sdk吧,可以去我的论坛上看看,针对微信游戏开发的。点我名字(上方蓝色字)
  • wayne5618 2015-02-06 10:42:13 回复
    回复 MVM : 老老实实微信的js-sdk吧,楼主的js在iOS中已经不能用了。
    微信封杀比较彻底。
    谁叫我们跟着微信混的,必须要在他的规则下玩了
    MVM said:

    微信版本:wechat 6.1
    IOS版本: 6.1.3
    手机型号:4s
    问题:
    微信中无法分享链接,发送朋友等。
  • MVM 2015-02-05 10:49:30 回复
    微信版本:wechat 6.1
    IOS版本: 6.1.3
    手机型号:4s
    问题:
    微信中无法分享链接,发送朋友等。
  • 懒懒的呐喊 2015-02-02 14:17:37 回复
    新的版本很好用,解决了我的问题,就是在ios下不能分享。
    想请教大神另外一个问题,如果pc上模拟微信登录oauth2的网页。尝试修改user agent,貌似微信做了修改不管用了?期待你的回复,先谢了!
  • keith 2015-01-29 15:10:52 回复
    回复 Alien : IOS 系统不能分享
    Alien said:
    非常抱歉各位,最近着实太忙,没时间折腾WeixinApi了,既然都已经有官方版本的,那大家还是耐心的使用下官方版本吧,有问题直接让官方提供解决方案,会更及时一些。
  • 雪地旅行者 2015-01-27 12:23:07 回复
    回复 imabc : 已经不能用了。而且在iPhone里同时引用weixinjs文件,会产生冲突。wx的方法都不可用
    imabc said:
    回复 Alien : 官方版本的效率太低了,你可以测试一下,所以说,大家还是喜欢用你写的。
  • imabc 2015-01-24 13:08:42 回复
    回复 Alien : 官方版本的效率太低了,你可以测试一下,所以说,大家还是喜欢用你写的。
    Alien said:
    非常抱歉各位,最近着实太忙,没时间折腾WeixinApi了,既然都已经有官方版本的,那大家还是耐心的使用下官方版本吧,有问题直接让官方提供解决方案,会更及时一些。
  • Alien 2015-01-22 21:18:39 回复
    非常抱歉各位,最近着实太忙,没时间折腾WeixinApi了,既然都已经有官方版本的,那大家还是耐心的使用下官方版本吧,有问题直接让官方提供解决方案,会更及时一些。
  • 小菜比 2015-01-22 10:10:45 回复
    回复 小树不坏 : 你这个问题解决了么?
    小树不坏 said:
    官方的那个需要验证是怎么个意思呢??普通公众号不能用?需要300一年认证么?
  • imabc 2015-01-21 18:43:14 回复
    6.1版本,不能用了。
  • 小菜比 2015-01-21 17:56:00 回复
    我想调用js-sdk中的getInstallState这个方法的用来检测当前设备有没有安装某个app,但是要开通官方权限,这个权限是什么?
  • we 2015-01-21 09:46:01 回复
    6.1之后,不能用了,大神,有解决方案吗?
  • bobbypz 2015-01-20 17:03:28 回复
    Notice: Trying to get property of non-object in D:\WWW\xuexiku\php\jssdk.php on line 70
    
    Notice: Undefined property: stdClass::$ticket in D:\WWW\xuexiku\php\jssdk.php on line 49
    
    用官方的js-sdk测试提示这个?求解
  • 本杰明 2015-01-20 13:28:33 回复
    去哪里可以下载这个js??
  • ilikecss 2015-01-20 12:17:22 回复
    微信官方的那个太复杂了,还要申请什么签名
  • 还有100条较早的评论...